Hi all,
I've got an issue with a Dante Card installed on an ESP00-II.
Through Dante Controller I configured its secondary port into Legacy Hardware, and changed its address into IP 192.168.0.90 / SN 255.255.255.0.
Now, even if rebooting the ESP, rebooting my PC (with address IP 192.168.0.254 / SN 255.255.255.0), disabling antivirus or firewall I've got this:
- the Dante Controller shows the ESP Dante card but without any field accessible
- All the fields show the "retrieving model information - please wait" message
- If I force an error, changing my PC IP address, the ESP Dante card field correctly turns red and a window says my PC is in a different subnet, showing the Dante card IP address 192.168.0.90, so I'm sure I changed its IP as I wanted (nothing I can say about SN).
- From a command prompt the Dante card doesn't respond to ping
Note that my PC is directly connected to the Primary port of the Dante card, and that I tried with another PC and the issue is the same.

Is there a way to factory restore the Dante Card, even in this situation?

Thanks to everybody for any suggestion.

Attachments

Photos (5)
Files (1)
Original Post
Hi Moreno,

Have you got multiple NICs active on your PC?

I suspect it may still be set to 'Obtain IP address automatically' - and has allocated itself a link-local address. If so it will be discovered - but a direct connection can't be made if there are multiple NICs active on your PC. Disable all other NICs (wireless, office etc.) so the only active NIC has the Dante connection and I suspect the rest of the info will populate in DC - and you'll see it has a link-local 169.254.x.x address..

Best regards
Rob
Hi Moreno,

I'm pretty sure that it's an IP address issue.
1 - You can see it on Dante Controller, but can't make any changes
2 - It does not appear in the CS Designer Dante interface.

As you probably know. It's best to use a router with DHCP the first time out of the box.

I've attached a screenshot of Dante Controller.
- In this case the PC is static on 192.168.0 which is the CS default.
- TheEP22 has a static address on another Network address. It shows up, but you can't do anything with it. If the Dante device is on the wrong CS Designer, it won't show up at all.
- You may have a device show up in the list that is red. The is a similar issue with IP mis-match. (I can't remember which combination at the moment)


I've been trying to nail down a process for this. First, disable wifi and unused NIC's. This will cause problems until all the Dante devices are on the same network address as the computer.

Try this:
1) Disable wifi and be sure you have only one network card enabled.
2) Put your computer network card into DHCP mode.
3) Connect the ESP with the power off.
4) Power up the ESP/PM.
5) This should assign the computer an IP address on the Dante default range of 169.245.X.X.
6) Use Dante Controller to assign addresses to the same Project Address as in CS Designer.
7) Now use CS Designer to update firmware.

I hope this helps.

John Rogers
Hi Rob,

I disabled all the other NICs, with no success.
As I already described, if I change my PC IP address, the ESP Dante card field on DC turns red, and it shows the Dante card IP address as 192.168.0.90. but if I put my PC on that subnet, still there's no way to configure the ESP Dante card.
I'm pretty sure it's still an IP mis-match.

Use the 'Device Info' tab in the main window of DC (Dante Controller) rather than 'Device View.' This lets you see the network information for everything on the Dante network.

Use 'ipconfig' from a command line to confirm you computer settings.

From a command window you can use the command 'arp -a' to see everything on the subnet of the computer. (THANKS BRIAN KAM)

Here's what's in the screenshot:
1) My computer is static at 192.168.0.7
2) Two of the devices are static on 192.168.0.x and appear as expected.
3) The EP22 is set to DHCP, but shows up and shows the IP address based on the MAC address or something DC is doing with the default range.
4) The PM showing as red is set to a static address of 192.168.10.230 which is a different subnet. It doesn't show in DC or with 'arp'

Also, make sure you power cycle the device. the 'Reboot' button won't work with our stuff. I'm not sure if someone else covered this.

Does this help?

JR
Hi all,

I really appreciate your help, thanks!

Anyhow, I can't find a way to proceed.

Here are my tests:

My PC network config is: STATIC IP 192.168.0.91 / SN 255.255.255.0
I open Dante Controller while the ESP00-II is off.
I connect my PC to the Primary Dante port of the ESP00-II, my PC has got this only NIC active.
I turn the ESP00-II on.
The ESP Dante Card appears on Dante controller as you can see in the attachment 'Network View'.
So it seems I'm connected...
But I double click on the Bose-ESP field and find what you can see in the attachment 'Device View'.
So, I don't know why, but the Dante card seems to have a SN 255.255.255.255 !! That's probably why I can't reach it through the ping command.
I try to change its IP configuration (Subnet or DHCP settings) but it's impossible, since while I'm changing the values, the card is disconnected (the Network view show only the device name of the Dante card, all the other fields become empty).

Then,
I reboot the ESP00-II.
After some seconds the Dante controller shows again all the infos about the Dante card as in the attachment 'Network view'.
if I click on the 'Reload Device Information' icon the Network view shows only the device name of the Dante card, all the other fields become empty.


Is there a way to hard reset the ESP Dante card?

Thanks.
Hi all,
don't ask me why, but I solved my issue in a way that I myself don't understand, but...
I had my ESP00 Dante card blocked on fixed IP 192.168.0.90 SN 255.255.255.255, and I'm quite sure I did't set that closed SN mask intentionally.
Well, only to see what happened, I set my PC network card in IP 192.168.0.90 SN 255.255.255.255 GW 192.168.0.90...
I started Dante Controller, I could change the Dante card IP setting to DHCP and reboot the card.
After resetting my PC card accordingly, I could reach the Dante card and control it as usual.
Mistery!
Dear Kind CSD Folks,

On a RM site visit last Friday, one of our contractor was having some Dante issues. After connecting to an errant PM8500N Dante card directly and rebooting, I was able to see it in Dante Controller long enough to identify the issue – it had inadvertently been set to a subnet mask of 255.255.255.255 on the primary - basically the same issue that Moreno had above. For a while, I thought I was going to trick it into resetting via the secondary connection (it had already been placed on static IP in redundant mode). It let me upgrade the firmware to 1.3.2 via the secondary port using the fum utility, but it still would not let me reset the address or route audio. It was showing up in Dante Controller after each new reboot and reporting its sorry state, but no changes were possible. While I did try most everythinbg that Moreno tried, I must admit that i didn't specifically set the Gateway address and just sent a note to the contractor to see if this made any difference (assuming that he hasn't replaced the card yet).

In my effort to grasp at straws last week, Brian Kam and I discussed the undocumented button on the circuit board. Is this a reset button? Apparently a reset button appears on many other manufacturer’s Dante interfaces. If so, there seems to be no easy way to power the card and hit this button without a wiring harness. When plugged into an amplifier, the button is way up near the contact pins. I wasn’t quite brave enough to take the face plate off and try to reach in there with a dental pick or something like that (preferably insulated) to push the button while it was powered on. I did try pushing and holding it when outside the chassis on the stray (and errant) thought that their might be enough of a stored energy charge to allow a reset – but as evidenced here, most any sort of logic flies out the window when I’m desperate. Ultimately, I sent the contractor back to our PTS team for a replacement card.

So – my question is – shouldn’t we have a field documented way of recovering from an error – i.e. a way to reset a card maybe with a concealed pin hole type opening or whatever – to get back to a starting point so that when a card is bricked or improperly addressed, we can recover in the field? Or has anyone tested Moreno's findings - hopefully someone that is equipped to recover from this sort of disaster in case a duplicate address with a /32 mask doesn't work. <smile>

Best regards,

Dave
Hi Dave,

I the latest version of the Audinate DC it is no longer possible to enter a subnet mask of 255.255.255.255 (/32)
If you do so, the apply button will be grayed out.

Also in the latest version of CSD DC this is no longer possible.
If you do so, a window will pop-up with the message that you cannot use a subnet mask of 0.0.0.0 and 255.255.255.255
Just to clarify what Moreno and Philippe have described.

When the Dante card has a subnet mask of 255.255.255.255 the network size is one and the only device that is in the network is the Dante card. To communicate with the card what they have done is to set the computer IP to an address that is not the same IP as the Dante card, but set the subnet mask for the computer to 255.255.255.255 and set the default gateway to the IP of the Dante card. This forces communication with any device outside of the computer's network of one to the default gateway, which is the Dante card.

If I have misspoke on any of this please add a correction.

Thanks.

Eric

Add Reply

Likes (0)
Post
Having trouble signing in?

We recently updated our sign-in procedure and if you have old sign-in data cached, this can create a problem. Please:

  1. Clear your browser cache and cookies
  2. Then close the browser (not just the window)
  3. Open the browser and try again
Thank you

Please make sure that your profile is up to date
×
×
×
×