Discussions about the new Bose S1 Pro

Bose S1 Pro

Bose S1 Pro 

Designed for musicians, DJs and general PA use, the S1 Pro is the ultimate all-in-one PA, floor monitor and practice amplifier that's ready to be your go-anywhere Bluetooth music system for nearly any occasion. 

This is the place to discuss the S1 Pro.

S1 Pro system battery not charging

Hi all...new to the forums!  So one of my S1 pro batteries was totally dead.  I haven't used it for a couple days, so I'm hoping that the switch accidentally got turned on.  Anyway, I fast-charged both speakers.  The other one charged up and the light went off, but the one that was dead is still flashing after almost 4.5 hours on fast charge.  Is this normal?  Could this battery be bad?

Original Post

Hi Durnbock,

Thank you for joining the Bose Portable PA Community. I'm sorry you're having an issue with the battery in one of your S1 Pro systems.

It sounds like the battery worked at one point a couple of days ago. Is that right?

Yes, it's possible that the switch got turned on and this would have drained the battery.

It should have charged up in within 4.5 hours on the fast charge position (pushed in at the bottom).  If it was in the middle position it can take 6 hours. Is the light flashing blue or red?

Let's try something for diagnostics. 

Put a piece of tape on the S1 Pro that isn't charging. Let's call that unit #2

Please remove the battery from the unit #s. Put some tape on it so you can keep track of it.  Install that battery in the other S1 Pro and try to charge it.

If it won't charge, please call Bose Support. There's a problem with the battery.

Put the known good battery in unit #2. Leave it on and let the battery run down.  Then charge it.

If unit #2 doesn't charge, please call Bose Support. There's a problem with unit #2.

Bose® Product & Technical Support at (877) 335-2673
(U.S. and Canada only)
Monday-Friday: 9:00 AM - 9:00 PM ET

If both units charge properly, then the battery in unit #2 wasn't seated correctly.  Now that both units are working correctly - everything is fine.

Does that help?

ST

Oops, forgot to say..the light is flashing BLUE.  It was red when I first tried to  use it.  I did the battery test and I get the 4 blue blinks that would indicate it is charged up, but the light still hasn't gone off to indicate it is done.  That is my concern.

Hi Durnbock,

Things may be fine.  Before you do all that switching around, give unit #2 another 30 minutes charging. That should be a full 6 hours by now.

Unplug the unit and disconnect everything from it. Let is sit for a full two minutes. Turn it back on.  Put it into the fast charge position - does the charging light go out within  few minutes?

If so, things are probably fine.

ST

Hi again Durnbock,

Have you done the S1 Pro System Update on both your S1 Pro systems?

If so, then you can use an IOS or Android device to install the Bose Connect app (follow the link above for details).

Then you can use the Bose Connect app to check the battery level on your S1 Pro systems. And there some other features to explore if you like to stream Bluetooth audio to your S1 Pro systems.

ST

Hi ST. Yes I did updates on both.   I tried unplugging like you suggested and the charge light still keeps flashing slowly.  I even took the battery out and reinstalled it and it is still doing it.  I will have to do the battery swap tomorrow to see if that makes a difference.  When I got these from Guitar Center, I recall one of the battery boxes was opened.  Perhaps they gave me a used or faulty battery. 

Well, I left it on a trickle charge when I went to bed, and when I got up about 3 hours later the light was off.  So maybe it was just SOOOO drained that it took longer to charge than normal?

I do appreciate the help!  This is a pretty big investment for me.

Thanks ST!  I plan on using them this weekend and then swapping the batteries, just to see if there is any charging issue--just to be safe.  My OCD is like that!

I am hoping to get into playing acoustic music, but right now these are perfect for traveling to jam with friends, as well as small karaoke parties.  I take a small mixer and that gives the volume a little boost.  I am also excited about the new app letting you link 2 together for Bluetooth--these will be great for tailgating!  But right now they save me from hauling my more traditional PA system for small jams and gathering!

Just wanted to give a quick update. I was able to finally use the S1 Pros all weekend jamming with a couple of friends. We ran an acoustic guitar, acoustic bass, drum machine, and vocals through a mixer into the 2 S1s and they still sounded phenomenal.  I even got to take them out fishing using my iPod with the app.

I was able to use them for a while on battery power and they both seem to be charging properly now--so maybe that one was just REALLY drained before. Since it looks like there is a warranty on the batteries, if I notice major issues I should be able to get a replacement. So hopefully they keep working!

But 2 of these sound really nice for a really small but still pretty loud PA for a small venue!

Well, got them out again today and one battery had 4 flashes, the other only 1 and they have both been used the same amount of time.  I am beginning to think I got a bad battery from Guitar Center.  Can I just contact Bose customer service to see about a replacement?

Either way, I’l still have to buy a new battery as I need them next week for an event and I don’t imagine any exchange will happen that quickly.  Darn it!

Hi Durnbock,

I'm sorry you're having a problem with one of your batteries.  Yes, you can call Bose Support, but it may be faster to deal with Guitar Center.

When I got these from Guitar Center, I recall one of the battery boxes was opened.  Perhaps they gave me a used or faulty battery. 

ST

Bose® Product & Technical Support at (877) 335-2673
(U.S. and Canada only)
Monday-Friday: 9:00 AM - 9:00 PM ET
 

Thanks ST.  I did talk to a Guitar Center in the Twin Cities.  Only one of the store there has 1 in stock.  They said it is not an item they will be able to restock easily since all of the S1 Pros ship with the batteries installed, so they will no longer be selling them.  I am guessing this means that in the future if batteries need replacing that we will have to deal directly with Bose?

Well, at first it seemed great.  But after using them a couple times, the new battery is taking forever to charge as well.  So now I am afraid that there is something wrong with that particular S1–like it isn’t charging properly.  I can’t believe I got  another bad battery.

I’m really bummed—even if I could replace the speaker, then I’ll have one with a bunch of use and another new.  I’m a little OCD in that I want them both to be pretty much the same!  So now I’m not sure what to do!

Hi Durnbock,

Please call Bose Support and tell them the whole story and see what they suggest.

Bose® Product & Technical Support at (877) 335-2673
(U.S. and Canada only)
Monday-Friday: 9:00 AM - 9:00 PM ET



Thanks.

ST

Add Reply

Likes (0)
Having trouble signing in?

We recently updated our sign-in procedure and if you have old sign-in data cached, this can create a problem. Please:

  1. Clear your browser cache and cookies
  2. Then close the browser (not just the window)
  3. Open the browser and try again
Thank you

Please make sure that your profile is up to date
×
×
×
×