This area of the community is for Bose Pro Portable PA owners who want an answer from a Bose employee. Posting here will notify a Bose employee by email, and the typical response times range from 4-24 hours if you post during service hours (see below) and 24-48 hours on weekends and US holidays.
You can also ask your question in the general forums where one of our knowledgeable Bose user community members can help you.

To ask Bose for help, click POST.

Additional information can be found at the Bose Pro Portable PA Wiki, where advice has been accumulated for over 12 years.

If you are looking for information about other Bose Products please contact:

L1 Model 2 Power Stand No Sound after failed Firmware Update

I have an L1 model model 2 with tone match. Last night i did and update of the Firmware, both of the ToneMatch and The L1 Model 2. I appears however that the L1 update was interrupted. I took the system to a memorial function today but to my dismay I couldn’t get sound from the L1 Model 2 and the ToneMatch says that the power stand is not connected.
I’ve tired several times to do a power cycle, re-download and redo the update but it has totally failed.
Please help I am in Zimbabwe.

I had carried with me two L1 portable versions and I had to use these for the function. The sound was not well enough though cause the function had over 300 people.

Original Post

Hi Ryan,

I'm sorry that happened to you. It does seem that the firmware update interruption caused this problem. If the T1 shows a firmware version for itself, but nothing for the "PS2" power stand, then the power stand would need to be serviced. We can service the power stand in the US or in Canada only. If you live in Zimbabwe, please email, our affiliate Bose Pro office in Zimbabwe. If you live in the US or Canada, please call 877-335-2673.


Chris J

Hi. I'm in Zimbabwe.

Twintrade emails are not being replied. I however called and they referred me to Solution Center who spent two days saying they're downloading the Technical Manuals. It seems they do not really have an idea.

Calling is a bit of a challenge due to the time difference. Could you please advise me on how I can send the PS for servicing. I need to use it for another big function on 2 September.

I really expected it to be simple considering that this is more of a software problem.




Hi Ryan,

I'm sorry for the trouble! 

We are a US-based service team and can only ship products within the US and Canada.  So let me reach out to our global service department to see what other avenues you have in Zimbabwe.   I would recommend contacting Solution Center again in the meantime though. 

I apologize for the inconvenience with this.  The last thing we want is for you to be stuck trying to find service and not getting any help.


Good day.

It's a Bose L1 Model 2 power stand sound system that I tried to do a firmware update. I suspect the update didn't go thru but then from then on the power stand just switches on but there's no sound. I've also contacted Bose and they said the unit will have to be serviced at a capable Bose Service Centre.

Could you please do me a favor and find out if you'd be able to service it for me.

I'm in Zimbabwe so once you can confirm for me that you can service it I'll courier it to you.


I've also got a second L1 Model 2 Power Stand which I had just bought. I connected it and as way of testing was playing music from my phone. It only worked for about 10 min and I heard a light pop sound and all power went off.

Feels like a fuse but then I tried other power cables and different socket wall outlets but still it doesn't power on. I'm not sure if it has an internal fuse



Hi Nick I'm still waiting for your assistance. I haven't had any joy from Solution Center.

While I was waiting for this to be sorted I got my sister to buy another L1 Model 2 PS, UK version this time around since I'm building another set. While is was testing it for the first time by playing music from my phone thru the analogue input, it just played music for about 10 mins, I then heard a very faint pop sound and all power went off. Thought it was a fuse so I've tried a different power cable and different wall outlets but it has totally refused to switch on ever since. This one costed me £1,100 imagine and I've lost so many functions now that wanted to hire the system.

Right now I have the system that costs over $6k but totally useless. Please help me.

Seriously shipping these items back is a big cost. It costed me £120 to ship the power stand from the U.K. To Zimbabwe.

By the way the first PS had a failed firmware update and needs service.


Hi Chris

I sent back the second new PS to the UK and they repaired it for free. I’m still stuck with the first one, the 110Volt one which had a failed firmware update, I’ve sent it to South Africa’s Alpha Tech who do Bose products but they seem not to have an idea of what needs to be done. They say the 110V Systems are sensitive to power surges and maybe something else is affected but I know it’s just a failed Firmware Update which can be resolved at a capable service Centre.

you had said you’ll check for me with your Global Service Department, I haven’t had feedback on that.

Add Reply

Likes (0)
Having trouble signing in?

We recently updated our sign-in procedure and if you have old sign-in data cached, this can create a problem. Please:

  1. Clear your browser cache and cookies
  2. Then close the browser (not just the window)
  3. Open the browser and try again
Thank you

Please make sure that your profile is up to date