New L1® updater v1.0 for Mac

We are pleased to announce the release of the L1® updater v1.0 for use with Mac. The L1® updater for Mac will support all of the same features as the L1® updater for PC.

Click here to download the L1® updater v. 1.0 for Mac.

Click here to download the L1® updater for Mac instructions.

System Requirements
Mac OS X version 10.3 or higher
USB 2.0

These items will also be available on the Musicians site at www.bose.com in the weeks to come.

Attachments

Photos (3)
Original Post
×
×
×
×